Feature #3064

depenency issues with nethserver-wordpress

Added by stephane de Labrusse over 4 years ago. Updated over 4 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:nf-closed
Resolution:DUPLICATE NEEDINFO:No

Description

Hi All

With the release of nethserver-wordpress in nethforge, I have seen that dependencies are not imported in nethforge and we need to manually enable  epel if we want to install that contribs.

It is not really important for me if we document that epel is a mandatory (less works if we want to follow updates) but that need to be decided. and written in the documentation ----> http://dev.nethserver.org/projects/nethforge/wiki/Nethserver-wordpress

for now

yum install nethserver-wordpress --enablerepo=nethforge --disablerepo=epel ----> Error: Package: nethserver-wordpress-1.0.0-2.ns6.noarch (nethforge) Requires: wordpress

but if I enable epel

yum install nethserver-wordpress --enablerepo=nethforge,epel

Installing:
nethserver-wordpress noarch 1.0.0-2.ns6 nethforge 17 k
Installing for dependencies:
enchant x86_64 1:1.5.0-4.el6 centos-base 49 k
hunspell x86_64 1.2.8-16.el6 centos-base 177 k
php-IDNA_Convert noarch 0.8.0-1.el6 epel 35 k
php-PHPMailer noarch 5.2.2-1.el6 epel 474 k
php-enchant x86_64 5.3.3-27.el6_5.2 centos-updates 30 k
php-getid3 noarch 1:1.9.7-1.el6 epel 420 k
php-simplepie noarch 1.3.1-3.el6 epel 465 k
wordpress noarch 4.1-1.el6 epel 4

Else I wonder if you need to manually add a contrib to the package manager because I can't find nethserver-wordpress when I use it ??

History

#1 Updated by stephane de Labrusse over 4 years ago

  • Status changed from NEW to CLOSED
  • % Done changed from 0 to 100

#2 Updated by Davide Principi over 4 years ago

  • Resolution set to DUPLICATE

Also available in: Atom PDF