Enhancement #2820

Embed Nethgui 1.6.0 into httpd-admin RPM

Added by Davide Principi over 5 years ago. Updated about 5 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:nethserver-httpd-admin
Target version:v6.5
Resolution: NEEDINFO:No

Description

Starting from version 1.6.0, Nethgui requires some external dependencies: adjust the *.spec file to include them, following Fedora SourceURL guidelines: http://fedoraproject.org/wiki/Packaging:SourceURL


Related issues

Related to NethServer 6 - Enhancement #2812: Build from plain .spec file enhanced CLOSED
Related to NethServer 6 - Enhancement #2794: Packagemanager: be more verbose in case of error CLOSED
Related to NethServer 6 - Bug #2798: Remote access: no valid netmask for single IP CLOSED
Related to Nethgui - Feature #2764: CIDR block validator CLOSED
Related to Nethgui - Feature #2817: Process Tracker module CLOSED
Related to Nethgui - Feature #2818: Customizable Notification templates CLOSED
Related to Nethgui - Enhancement #2819: View::getCommandList() API deprecation CLOSED

Associated revisions

Revision 7768d8a5
Added by Davide Principi over 5 years ago

Use Composer to manage dependencies. Refs #2820

Nethgui is no longer an RPM package: it must be embedded into another
RPM requiring it. See nethserver-httpd-admin package, for instance.

Revision dbae3af5
Added by Davide Principi over 5 years ago

Updated dependencies for Nethgui 1.6.0. Refs #2820

Revision 8e98febf
Added by Davide Principi over 5 years ago

pkgaction: print error messages to stderr. Refs #2820

Revision 6dbebac7
Added by Davide Principi over 5 years ago

ptrack: exit with non-zero exit code if command does not exist. Refs #2820

Revision 2e2b4b37
Added by Davide Principi over 5 years ago

ptrack: changed progress and dump format. Refs #2820

Revision 7ebafd0d
Added by Davide Principi about 5 years ago

pkgaction: exit with non-zero value if events fail. Refs #2820

The new Tracker module from Nethgui requires non-zero process exit
code to detect an error condition.

Revision f456974a
Added by Davide Principi about 5 years ago

event actions: Report error reason, when possible. Refs #2820

When a task has non-zero exit code the message can specify the error
reason. If the message is empty, the reason should be provided by a
more specific sub-task.

Revision 258e34b8
Added by Davide Principi about 5 years ago

ptrack: daemonize() and use syslog. Refs #2820

UI configuration is read from stdin in JSON format before fork()ing.

Revision 997fa412
Added by Davide Principi about 5 years ago

PackageManager: use Tracker module from Nethgui 1.6. Refs #2820

Revision e5e661f4
Added by Davide Principi about 5 years ago

Merge branch 'b2820' Refs #2820

Embed Nethgui 1.6.0 into httpd-admin RPM

Revision e8f3e75b
Added by Davide Principi about 5 years ago

LocalNetwork, Organization, RemoteAccess UI modules: background task event. Refs #2820

When httpd-admin is reloaded/restarted, prevent errors caused by
smwingsd/httpd-admin shutting down their sockets.

Revision 069a2528
Added by Davide Principi about 5 years ago

Nethesis template: use Nethgui 1.6 Notification and Tracker output slots. Refs #2820

Also, include CSS Font Awesome.

Revision 55f598fc
Added by Davide Principi about 5 years ago

FirewallRules/Index page: Font Awesome included by nethserver-base. Refs #2820

Revision b0898286
Added by Davide Principi about 5 years ago

Use default Notification CSS styles from Nethgui. Refs #2820

Revision 758c1680
Added by Davide Principi about 5 years ago

Include styled Notifications from Nethgui. Refs #2820

Revision 50e6402e
Added by Davide Principi about 5 years ago

Silently stop httpd-admin during RPM transaction. Refs #2820

Revision f56f0734
Added by Davide Principi about 5 years ago

Fake Tracker module for backward compatibility. Refs #2820

fixes commit:997fa41

History

#1 Updated by Davide Principi over 5 years ago

#2 Updated by Davide Principi over 5 years ago

  • Status changed from TRIAGED to ON_DEV
  • Assignee set to Davide Principi
  • % Done changed from 20 to 30

#3 Updated by Davide Principi about 5 years ago

  • Related to Enhancement #2794: Packagemanager: be more verbose in case of error added

#4 Updated by Davide Principi about 5 years ago

New guideline for ptrack clients:

When a task has non-zero exit code the message can specify the error
reason. If the message is empty, the reason should be provided by a
more specific sub-task.

#5 Updated by Davide Principi about 5 years ago

  • Status changed from ON_DEV to MODIFIED
  • Assignee deleted (Davide Principi)
  • % Done changed from 30 to 60

Changes

  • Removed Module/Tracker and Tool/Tracker from PackageManager, use new Tracker from Nethgui
  • LocalNetwork, Organization, RemoteAccess pages use new Tracker, too
  • Changed messages to ptrack from runlevel-adjust adjust-services generic_template_expand
  • Updated pkgaction to new ptrack guidelines (see above note-4)

Test case

Check changed pages still work correctly.

#6 Updated by Davide Principi about 5 years ago

  • Status changed from MODIFIED to ON_QA
  • % Done changed from 60 to 70

In nethserver-testing:
nethserver-base-2.2.1-69.0gite8f3e75b.ns6.noarch.rpm
nethserver-lib-2.0.3-8.0gitcc259027.ns6.noarch.rpm
nethserver-yum-1.3.1-4.0git52ee49b5.ns6.noarch.rpm
nethserver-httpd-admin-1.2.3-99.15git47a1ac7.ns6.noarch.rpm
nethserver-base-2.2.1-70.0git069a2528.ns6.noarch.rpm
nethserver-firewall-base-1.1.0-102.0git55f598fc.ns6.noarch.rpm
nethserver-httpd-admin-1.2.3-99.17git758c168.ns6.noarch.rpm

nethserver-base-2.2.1-71.0gitf56f0734.ns6.noarch.rpm
nethserver-httpd-admin-1.2.3-100.19git30cc174.ns6.noarch.rpm
nethserver-httpd-admin-1.2.3-100.20git398cc77.ns6.noarch.rpm

#7 Updated by Davide Principi about 5 years ago

  • Related to Bug #2798: Remote access: no valid netmask for single IP added

#8 Updated by Giacomo Sanchietti about 5 years ago

  • Assignee set to Giacomo Sanchietti

#9 Updated by Davide Principi about 5 years ago

#10 Updated by Davide Principi about 5 years ago

#11 Updated by Davide Principi about 5 years ago

  • Related to Feature #2818: Customizable Notification templates added

#12 Updated by Davide Principi about 5 years ago

#13 Updated by Filippo Carletti about 5 years ago

  • Status changed from ON_QA to VERIFIED
  • % Done changed from 70 to 90

#14 Updated by Davide Principi about 5 years ago

  • Status changed from VERIFIED to CLOSED
  • Assignee deleted (Giacomo Sanchietti)
  • % Done changed from 90 to 100

In nethserver-updates:
nethserver-base-2.3.0-1.ns6.noarch.rpm
nethserver-firewall-base-2.0.0-1.ns6.noarch.rpm
nethserver-httpd-admin-1.3.0-1.ns6.noarch.rpm
nethserver-httpd-admin-1.3.0-2.ns6.noarch.rpm (0001-NullRequest-fixed-User-object-creation.patch)
nethserver-lib-2.1.0-1.ns6.noarch.rpm
nethserver-yum-1.3.2-1.ns6.noarch.rpm

Also available in: Atom PDF