Feature #2754

phpMyAdmin

Added by Giacomo Sanchietti over 5 years ago. Updated over 5 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:nethserver-phpmyadmin
Target version:nf-closed
Resolution: NEEDINFO:No

Description

Add phpMyAdmin integration.

The new module will:
  • force connections on SSL
  • give access to root/admin user

QA2754-nethserver-phpmyadmin.txt Magnifier - yum install output (4.75 KB) Davide Principi, 08/18/2014 04:51 AM

0001-Release-1.0.0.patch Magnifier - 1.0.0 release (757 Bytes) Davide Principi, 08/18/2014 06:38 AM

0002-.spec.in-point-URL-tag-to-dev.nethserver.org.patch Magnifier - proposed patch (766 Bytes) Davide Principi, 08/18/2014 06:54 AM

Associated revisions

Revision 2ab8dfbe
Added by stephane de Labrusse over 5 years ago

modified spec file

History

#1 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from NEW to TRIAGED
  • % Done changed from 0 to 20

#2 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from TRIAGED to MODIFIED
  • Assignee set to stephane de Labrusse
  • % Done changed from 20 to 60

Ready to build an RPM for QA.

#3 Updated by stephane de Labrusse over 5 years ago

  • File nethserver-phpmyadmin-3.5.8.2-1.ns6.src.rpm added
  • File nethserver-phpmyadmin-3.5.8.2-1.ns6.noarch.rpm added

Giacomo Sanchietti wrote:

Ready to build an RPM for QA.

not sure that I understand well How works your QA process This is the binaries (src and rpm), tested by my own, but it needs certainly more testers to improve that release.

see the wiki on how to use it : nethserver-phpmyadmin

all dependencies come from EPEL

#4 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from MODIFIED to ON_QA
  • Assignee deleted (stephane de Labrusse)
  • % Done changed from 60 to 70

I've create the rpm which is available directly from nethforge-testing.

To install and test:

yum localinstall http://pulp.nethserver.org/nethserver/nethserver-nethforge-release.rpm -y
yum --enablerepo=nethforge-testing install nethserver-phpmyadmin

#5 Updated by Davide Principi over 5 years ago

  • Category set to nethserver-phpmyadmin

#6 Updated by stephane de Labrusse over 5 years ago

no release in nethforge instead of nethforge-testing, there are still some issues ?

#7 Updated by Davide Principi over 5 years ago

  • Assignee set to Davide Principi

#8 Updated by Davide Principi over 5 years ago

VERIFIED

  • No installation problems (QA2754-nethserver-phpmyadmin.txt), nethserver-phpmyadmin-update event succeeded.
  • Logged in with admin's credentials and created a new database.

#9 Updated by Davide Principi over 5 years ago

In nethforge:
mod_authnz_external-3.2.6-1.el6.x86_64.rpm
pwauth-2.3.10-5.el6.x86_64.rpm
php-php-gettext-1.0.11-3.el6.noarch.rpm
phpMyAdmin-3.5.8.2-1.el6.noarch.rpm
nethserver-phpmyadmin-1.0.0-1.ns6.noarch.rpm

Notes to module Maintainer:
built from master branch 2ab8dfbe on GitHub

Please, apply 0001-Release-1.0.0.patch and tag the commit as 1.0.0 before pushing it to the official repository.

For future releases, could you apply attachment:0002-.spec.in-point-URL-tag-to-dev.nethserver.org.patch to clarify the RPM origin?

#10 Updated by Davide Principi over 5 years ago

  • File deleted (nethserver-phpmyadmin-3.5.8.2-1.ns6.src.rpm)

#11 Updated by Davide Principi over 5 years ago

  • File deleted (nethserver-phpmyadmin-3.5.8.2-1.ns6.noarch.rpm)

Also available in: Atom PDF