Bug #3389

Potential backup data corruption

Added by Filippo Carletti over 3 years ago. Updated over 3 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:<multiple packages>
Target version:v6.7
Security class: Resolution:
Affected version:v6.7 NEEDINFO:No

Description

duplicity has a problem of data corruption in case of resumed backups (uncommon in NethServer because we do not offer scp/sftp backups).
More details here:
https://bugs.launchpad.net/duplicity/+bug/1252484
Thanks to Artem for the heads up.

History

#1 Updated by Filippo Carletti over 3 years ago

  • Status changed from NEW to TRIAGED
  • % Done changed from 0 to 20

A new package is available from epel.
To updatel:

yum --enablerepo=nethserver-testing update duplicity

I tested it on two different server where I have enabled sftp backup and I found no problems.

#2 Updated by Giacomo Sanchietti over 3 years ago

  • Category set to <multiple packages>
  • Status changed from TRIAGED to MODIFIED
  • % Done changed from 20 to 60

#3 Updated by Giacomo Sanchietti over 3 years ago

  • Status changed from MODIFIED to ON_QA
  • % Done changed from 60 to 70
Packages in nethserver-testing:
  • python-lockfile-0.8-3.el6.noarch.rpm (already in nethserver-base)
  • duplicity-0.6.26-2.el6.x86_64.rpm
Test case
  • Configure a full backup data
  • Execute the backup
  • Upgrade duplicity from nethserver-testing:
     yum --enablerepo=nethserver-testing update duplicity
    
  • Re-execute the backup and check it ends correctly

#4 Updated by Giacomo Sanchietti over 3 years ago

  • Assignee set to Giacomo Sanchietti

#5 Updated by Giacomo Sanchietti over 3 years ago

  • Status changed from ON_QA to VERIFIED
  • Assignee deleted (Giacomo Sanchietti)
  • % Done changed from 70 to 90

Duplicity can correctly execute a differential backup on a backup already done with the previous release.

#6 Updated by Giacomo Sanchietti over 3 years ago

  • Status changed from VERIFIED to CLOSED
  • % Done changed from 90 to 100
Released in 6.7/nethserver-updates:
  • duplicity-0.6.26-2.el6.x86_64.rpm

Also available in: Atom PDF