Feature #1531

Base: package installation progress tracking and UI locking

Added by Davide Principi about 7 years ago. Updated about 6 years ago.

Status:CLOSEDStart date:07/12/2013
Priority:NormalDue date:07/15/2013
Assignee:-% Done:

100%

Category:nethserver-base
Target version:v6.5-beta3
Resolution:DUPLICATE NEEDINFO:No

Description

Package operations are long-running tasks that must be tracked by a progress indicator and can't run concurrently.

UI must display the installation state.


Related issues

Related to NethServer 6 - Feature #468: Package manager UI module CLOSED 09/13/2011 10/29/2012
Related to NethServer 6 - Enhancement #1748: Base: select multiple items in package-manager CLOSED 07/11/2013 07/12/2013
Related to NethServer 6 - Bug #2041: Yum transaction aborted while installing nethserver-file-... CLOSED 07/16/2013 07/16/2013
Related to NethServer 6 - Feature #1767: Base: new PackageManager UI module CLOSED 07/11/2013 07/12/2013
Duplicates NethServer 6 - Feature #2029: Process tracking and notifications CLOSED 06/18/2013 11/14/2013

History

#1 Updated by Davide Principi almost 7 years ago

  • Project changed from 34 to NethServer 6

#3 Updated by Davide Principi over 6 years ago

  • Target version changed from ~FUTURE to v6.4-beta1
  • Estimated time set to 8.00

This is related to #1748

#4 Updated by Giacomo Sanchietti over 6 years ago

  • Priority changed from Normal to Low

#5 Updated by Giacomo Sanchietti over 6 years ago

  • Target version changed from v6.4-beta1 to ~FUTURE
  • Parent task set to #1767

#6 Updated by Giacomo Sanchietti over 6 years ago

  • Target version changed from ~FUTURE to v6.4-beta2

#7 Updated by Davide Principi over 6 years ago

  • Status changed from NEW to TRIAGED
  • Priority changed from Low to Normal
  • % Done changed from 0 to 20

#8 Updated by Davide Principi over 6 years ago

  • Subject changed from Package installation progress tracking and UI locking to Base: package installation progress tracking and UI locking

#9 Updated by Davide Principi over 6 years ago

  • Due date set to 07/15/2013
  • Status changed from TRIAGED to ON_DEV
  • Assignee set to Davide Principi
  • Start date set to 07/12/2013
  • % Done changed from 20 to 30

#10 Updated by Davide Principi over 6 years ago

  • Parent task deleted (#1767)

#11 Updated by Giacomo Sanchietti about 6 years ago

  • Target version changed from v6.4-beta2 to v6.5-beta3

#12 Updated by Davide Principi about 6 years ago

  • Tracker changed from Feature to Task
  • Status changed from ON_DEV to NEW
  • % Done changed from 30 to 0

This issue is a duplicate of #2029

#13 Updated by Davide Principi about 6 years ago

  • Tracker changed from Task to Feature
  • Status changed from NEW to CLOSED
  • Assignee deleted (Davide Principi)
  • % Done changed from 0 to 100
  • Resolution set to DUPLICATE
  • NEEDINFO set to No

Duplicates #2029

Also available in: Atom PDF