Enhancement #3367

dangerous behaviour in the RestoreData page of nethserver

Added by christian giulioni about 2 years ago. Updated almost 2 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:v6.7
Resolution:WORKSFORME NEEDINFO:No

Description

i would report an issue that can drive ppl to make some very annoying/dangerous mistakes

- nethserver enterprise --> page RestoreData
- instead of looking manually for the folder to be restored you search a word in the textbox
- you key a word and use "enter" for executing
- you select one or more folder or you do some click in the folder tree
- then you come back above in the page in order to search another word
- you put another word and use again "enter"

the last "enter" do not run a second search but the restore process on the last selected folder in the tree, at least this is the behaviour i noticed

in my opinion, when user put the focus in the search textbox the page code should make the "enter" key come back to run the search and not the restore, because it is against every intuitive meaning and start totally unwanted restore processes

tnx, have a nice day

History

#1 Updated by Filippo Carletti about 2 years ago

I cannot reproduce the behavior described. Every time I hit enter, a new search is completed and relevant text highlighted.
I used chrome 49 for my tests.

What browser did you use?

#2 Updated by christian giulioni about 2 years ago

good afternoon Filippo

i had firefox 44.0.2 in that try

now i have 45.0 and tried again
you are right: the selected folder is ignored (and doesn't de-select) and the 2nd search is performed correctly after just 5-10s of delay

mmh...

last time the delay we noticed for the (maybe!) second search has been long for more than 10 minutes: i had time to write to assistance, to call by phone, wait 2 calls in the queue, and then M.P. killed the process whatever it was doing. since the selected folder was THE WHOLE folder of our email we tought it was restoring... maybe i fall in panic without reason?

so thank you a lot

#3 Updated by Filippo Carletti about 2 years ago

  • Status changed from NEW to CLOSED
  • % Done changed from 0 to 100
  • Resolution set to WORKSFORME

Thank you for reporting the issue.

#4 Updated by Giacomo Sanchietti almost 2 years ago

  • Target version set to v6.7

Also available in: Atom PDF