Enhancement #3345

Use AD groups for SquidGuard profiles

Added by Nicola Rauso over 3 years ago. Updated over 3 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:nethserver-squidguard
Target version:v6.7
Resolution:REJECTED NEEDINFO:No

Description

Scenario:

  • AD domain controller
  • NethServer act like AD member
  • Squid authenticated with different SquidGuard enabled

You cannot set different profiles on squidGuard using AD groups because they're not available from SquidGuard interface.

From shell you can get the list AD groups:

wbinfo -g

so, it appears to be a web interface limitation.

History

#1 Updated by Giacomo Sanchietti over 3 years ago

  • Status changed from NEW to CLOSED
  • % Done changed from 0 to 100
  • Resolution set to REJECTED

You could create a profile which is using an AD group inside a profile, with a command like this:

db contentfilter setprop profile01 Src "group;mygroupfromad" 
signal-event nethserver-squidguard-save

The template will correctly expand the group into a list of AD users, but if the group is changed inside the AD, you have no way to propagate the modification to squidguard configuration.

This type of configuration will lead to unexpected behavior really hard to track down, definitively this is not a scenario we can fully support.

#3 Updated by Filippo Carletti over 3 years ago

  • Target version set to v6.7

Also available in: Atom PDF