Enhancement #3260

Obsolete nethserver-password by merging it into nethserver-directory

Added by Davide Principi about 4 years ago. Updated about 4 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:nethserver-directory
Target version:v6.7-rc1
Resolution: NEEDINFO:No

Description

# rpm -qR nethserver-password
nethserver-directory

This is correct but does not guarantee the password policy function is available on every system.

Associated revisions

Revision 27faacad
Added by Davide Principi about 4 years ago

Merged package nethserver-password. Refs #3260

  • .spec: obsolete nethserver-password
  • added migration fragment to fix existing user records in accounts
    DB, by adding PassExpires prop

Revision 6a5429a7
Added by Davide Principi about 4 years ago

Fixed migration fragment to set PassExpires prop. Refs #3260

Revision 2f4ca01d
Added by Davide Principi about 4 years ago

Removed nethserver-password from iso group. Refs #3260

History

#1 Updated by Davide Principi about 4 years ago

  • Status changed from TRIAGED to ON_DEV
  • Assignee set to Davide Principi
  • % Done changed from 20 to 30

Davide Principi wrote #3258:

Note: remove nethserver-password from nethserver-iso YUM group

#2 Updated by Davide Principi about 4 years ago

  • Status changed from ON_DEV to MODIFIED
  • Assignee deleted (Davide Principi)
  • % Done changed from 30 to 60

Test case

  • during the system upgrade from 6.6 to 6.7:
    • if nethserver-password is installed it will be removed by the updated nethserver-directory package
    • the prop PassExpires is added to all user records into accounts DB
  • on a (clean) 6.7 installation the password policy page and the password expire settings under User > Edit must behave correctly

#3 Updated by Davide Principi about 4 years ago

  • Status changed from MODIFIED to ON_QA
  • % Done changed from 60 to 70

In nethserver-testing/6.7
nethserver-directory-2.2.3-1.8.g27faaca.ns6.noarch.rpm

#4 Updated by dz0 0te about 4 years ago

  • Assignee set to dz0 0te

#5 Updated by dz0 0te about 4 years ago

  • Status changed from ON_QA to TRIAGED
  • Assignee deleted (dz0 0te)
  • % Done changed from 70 to 20

System and Package Version installed
VM KVM - Clean install of Nethserver 6.6 fully updated
Package Installed: nethserver-password-1.0.3-1.ns6.noarch
Other Package installed: ...

Test Original Problem
Enhancement

Install Updated Package

yum update --enablerepo=nethserver-testing nethserver-directory-2.2.3-1.8.g27faaca.ns6

Test Results after install
Test case 1: OK
fully update 6.6 with nethserver-password installed, upgrade to 6.7, then update nethserver-directory from testing
  • removed nethserver-password when updating nethserver-directory - OK
  • the prop PassExpires is added to all user records into accounts DB - OK
  • (prop PassExpires seems alredy present on all my account DB if nethserver-password is present on 6.6 before upgrade on 6.7)
Test case 2: NO
fully update clean 6.6 without nethserver-password, upgrade to 6.7, then update nethserver-directory from testing
  • the prop PassExpires is not present for existing users. From webUI after the update, Password Expiration is unchecked.
  • the prop PassExpires it's correctly created (and then managed) when enabling password expire settings under User > Edit
Test case 3: OK
  • installed 6.7b1 from iso, fully updated, then update nethserver-directory from testing
    (6.7b1 has already installed nethserver-password-1.0.3-1.ns6.noarch, correctly removed)
  • password policy page and the password expire settings, it correctly change relative DB/prop

Verified or Reopen
Reopen

Note

#6 Updated by Davide Principi about 4 years ago

  • Status changed from TRIAGED to MODIFIED
  • % Done changed from 20 to 60

Hi dz00te,
I tried to reproduce your test cases. There was an error in the migration fragment! Please, could you check your log messages and see if there are similar lines:

Sep 21 10:48:02 vm3 esmith::event[5120]: ERROR in /etc/e-smith/db/accounts/migrate//issue3260.ns6_7: Program fragment delivered error <<Can't call method "users" without a package or object reference at /etc/e-smith/db/accounts/migrate//issue3260.ns6_7 line 10.>> at template line 1
Sep 21 10:48:02 vm3 esmith::event[5120]: ERROR: Template processing failed for /: 1 fragment generated errors
Sep 21 10:48:02 vm3 esmith::event[5120]:  at /usr/share/perl5/vendor_perl/esmith/DB.pm line 459

Note
when upgrading from 6.6 to 6.7, use the package from nethserver-testing directly. You can achive this with

echo '6.7' > /etc/yum/vars/distroversion
yum  --enablerepo=nethserver-testing update

#7 Updated by Davide Principi about 4 years ago

  • Status changed from MODIFIED to ON_QA
  • % Done changed from 60 to 70

In nethserver-testing/6.7
nethserver-directory-2.2.3-1.9.g6a5429a.ns6.noarch.rpm

#8 Updated by dz0 0te about 4 years ago

  • Assignee set to dz0 0te

#9 Updated by dz0 0te about 4 years ago

yes, i have that error, i'm sorry i forgot to paste...

Sep 17 19:05:16 ns6fresh esmith::event[3118]: ERROR in /etc/e-smith/db/accounts/migrate//issue3260.ns6_7: Program fragment delivered error <<Can't call method "users" without a package or object reference at /etc/e-smith/db/accounts/migrate//issue3260.ns6_7 line 10.>> at template line 1
Sep 17 19:05:16 ns6fresh esmith::event[3118]: ERROR: Template processing failed for /: 1 fragment generated errors
Sep 17 19:05:16 ns6fresh esmith::event[3118]:  at /usr/share/perl5/vendor_perl/esmith/DB.pm line 459

now i'll test the new package...

#10 Updated by dz0 0te about 4 years ago

  • Status changed from ON_QA to VERIFIED
  • Assignee deleted (dz0 0te)
  • % Done changed from 70 to 90

System and Package Version installed
VM KVM - Clean install of Nethserver 6.6 fully updated
Package Installed: nethserver-password-1.0.3-1.ns6.noarch
Other Package installed: File server, Web server

Test Original Problem
Enhancement

Install Updated Package

yum update --enablerepo=nethserver-testing nethserver-directory-2.2.3-1.9.g6a5429a.ns6

Test Results after install
Test case 1: OK
fully update 6.6 with nethserver-password installed, upgrade to 6.7, then update nethserver-directory from testing
  • removed nethserver-password when updating nethserver-directory - OK
  • the prop PassExpires is added to all user records into accounts DB - OK
  • expire settings under User > Edit and Password Policies works correctly
Test case 2: OK
fully update clean 6.6 without nethserver-password, upgrade to 6.7, then update nethserver-directory from testing
  • the prop PassExpires is added to all user records into accounts DB - OK
  • expire settings under User > Edit and Password Policies works correctly
Test case 3: OK
installed 6.7b1 from iso, fully updated, then update nethserver-directory from testing
  • (6.7b1 has already installed nethserver-password-1.0.3-1.ns6.noarch, correctly removed)
  • password policy page and the password expire settings, it correctly change relative DB/prop
Test case 4: OK
upgrading from 6.6 to 6.7 using the package from nethserver-testing directly
  • the prop PassExpires is added to all user records into accounts DB - OK
  • expire settings under User > Edit and Password Policies works correctly

Verified or Reopen
Verified

Note

#11 Updated by Davide Principi about 4 years ago

  • Status changed from VERIFIED to CLOSED
  • % Done changed from 90 to 100

CLOSED

In nethserver-base/6.7
nethserver-directory-2.3.0-1.ns6.noarch.rpm

Also available in: Atom PDF