Bug #2920

Red interface: gateway setting wiped out

Added by Davide Principi about 5 years ago. Updated about 5 years ago.

Status:CLOSEDStart date:
Priority:ImmediateDue date:
Assignee:-% Done:

100%

Category:nethserver-base
Target version:v6.5
Security class: Resolution:
Affected version:v6.5 NEEDINFO:No

Description

The gateway setting is lost on red interfaces with static IP assignment

Package
nethserver-base-2.5.0-1.ns6.noarch

Associated revisions

Revision 29d6400d
Added by Davide Principi about 5 years ago

interface-config-write: fix gateway settings on S&G machines. Refs #2920

This fix avoids skipping the gateway setting on red interfaces with
static IP assignment.

History

#1 Updated by Davide Principi about 5 years ago

  • Status changed from TRIAGED to ON_DEV
  • % Done changed from 20 to 30

#2 Updated by Davide Principi about 5 years ago

  • Status changed from ON_DEV to MODIFIED
  • % Done changed from 30 to 60

Modified

#3 Updated by Davide Principi about 5 years ago

  • Status changed from MODIFIED to ON_QA
  • Assignee deleted (Davide Principi)
  • % Done changed from 60 to 70

In nethserver-testing:
nethserver-base-2.5.0-1.0git26b77e2c.ns6.noarch.rpm

#4 Updated by Filippo Carletti about 5 years ago

  • Status changed from ON_QA to VERIFIED
  • % Done changed from 70 to 90

Installed nethserver-base-2.2.1-68.0git997fa412.ns6.noarch.
Server with dhcp red: no GATEWAY.
Server with static red: GATEWAY=.

#5 Updated by Davide Principi about 5 years ago

  • Status changed from VERIFIED to CLOSED
  • % Done changed from 90 to 100

In nethserver-updates
nethserver-base-2.5.1-1.ns6.noarch.rpm

Also available in: Atom PDF