Enhancement #2763

Fetchmail: migration

Added by Giacomo Sanchietti over 5 years ago. Updated over 5 years ago.

Status:CLOSEDStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:nethserver-fetchmail
Target version:v6.5
Resolution: NEEDINFO:No

Description

Add scripts for migration from old fetchmail package.

Data to be migrated:
  • accounts from fetchmail db: same syntax, add proto property with default value pop3
  • fetchmail key from configuration db:
    • external_freq -> externalFreq

Associated revisions

Revision 10ac4f7b
Added by Giacomo Sanchietti over 5 years ago

createlinks, actions: add migration. Refs #2763

History

#1 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from NEW to TRIAGED
  • Target version set to v6.5
  • % Done changed from 0 to 20

#2 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from TRIAGED to ON_DEV
  • Assignee set to Giacomo Sanchietti
  • % Done changed from 20 to 30

#3 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from ON_DEV to MODIFIED
  • % Done changed from 30 to 60

#4 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from MODIFIED to ON_QA
  • Assignee deleted (Giacomo Sanchietti)
  • % Done changed from 60 to 70
Package in nethserver-testing:
  • nethserver-fetchmail-1.0.3-1.0git10ac4f7b.ns6.noarch.rpm
Test case
  • Prepare a fake migration environment:
    
    mkdir -p /var/lib/nethserver/migration/home/e-smith/db
    mkdir -p /var/lib/nethserver/migration/root
    cat <<EOF > /var/lib/nethserver/migration/home/e-smith/db/configuration
    ConsoleMode=login
    ContactEmail=
    ContactName=
    ContactOrg=
    MinUid=500
    SystemName=demo
    ldap=service|TCPPorts|389,636|access|private|defaultCity|Ottawa|defaultCompany|XYZ Corporation|defaultDepartment|Main|defaultPhoneNumber|555-5555|defaultStreet|123 Main Street|status|enabled
    maxAcctNameLength=31
    maxGroupNameLength=31
    maxIbayNameLength=12
    modSSL=service|CipherSuite|ALL:!aNULL:!ADH:!eNULL:!LOW:!EXP:RC4+RSA:+HIGH:+MEDIUM|TCPPort|443|access|public|status|enabled
    passwordstrength=configuration|Admin|strong|Ibays|strong|MaxPassAge|180|MinPassAge|0|PassExpires|yes|PassWarning|7|Users|strong
    syslog=service|LogAll2VT6|no|status|enabled
    fetchmail=service|FreqOffice|every15min|FreqOutside|every15min|FreqWeekend|every15min|Method|standard|SecondaryMailAccount|popaccount|SecondaryMailPassword|poppassword|SecondaryMailServer|mail.myisp.xxx|external_freq|disabled|status|disabled
    EOF
    
    cat <<EOF > /var/lib/nethserver/migration/home/e-smith/db/fetchmail
    test1@mail.com=fetchmail|account|test1|active|YES|nokeep|NO|password|112233|popserver|pop3.mail.com|ssl|NO|username|test1@mail.com
    EOF
    
  • Execute migration:
    /etc/e-smith/events/actions/nethserver-fetchmail-migrate migration-import /var/lib/nethserver/migration/
    
  • Check all accounts are migrated with a new property proto set to pop3
  • Check the status property is consistent
  • Check externalFreq is set to 15 minutes

#5 Updated by Filippo Carletti over 5 years ago

  • Status changed from ON_QA to VERIFIED
  • % Done changed from 70 to 90
  • Account migrated and set to pop3
  • status migrated (tested both enabled and disabled)
  • externalFreq set to 15 even if it was Every30min

#6 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from VERIFIED to CLOSED
  • % Done changed from 90 to 100

#7 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from CLOSED to ON_QA
  • % Done changed from 100 to 70

Back to QA -> VERIFIED

The issue is already verified but not released.

#8 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from ON_QA to VERIFIED
  • % Done changed from 70 to 90

#9 Updated by Giacomo Sanchietti over 5 years ago

Wait for #2766

#10 Updated by Giacomo Sanchietti over 5 years ago

  • Status changed from VERIFIED to CLOSED
  • % Done changed from 90 to 100
Released in nethserver-updates:
  • nethserver-fetchmail-1.0.4-1.ns6.noarch.rpm

Also available in: Atom PDF