Enhancement #1793

Httpd: avoid module is already loaded warnings

Added by Davide Principi over 6 years ago. Updated over 6 years ago.

Status:CLOSEDStart date:03/26/2013
Priority:NormalDue date:03/26/2013
Assignee:-% Done:

100%

Category:nethserver-httpd
Target version:v6.4-beta1
Resolution: NEEDINFO:

Description

[Mon Mar 25 18:35:02 2013] [warn] module proxy_module is already loaded, skipping
[Mon Mar 25 18:35:02 2013] [warn] module proxy_http_module is already loaded, skipping

LoadModule directives are expanded after conf.d/*.conf inclusion.

Warnings can be avoided
  • by adding IfModule checks, or
  • by assuming those checks are always done by included *.conf files and moving inclusion after LoadModule section.

Related issues

Related to NethServer 6 - Bug #1791: Httpd: files/ cgi-bin/ dirs not accessible for migrated i... CLOSED 03/26/2013 03/26/2013
Related to NethServer 6 - Bug #1792: Httpd: httpd.conf SSLProtocol value error CLOSED 03/26/2013 03/26/2013

Associated revisions

Revision ce336782
Added by Davide Principi over 6 years ago

httpd.conf template: module fragment is expanded before base fragment. *.conf, *.ibay and *.vhost Include must now check if a module is loaded (IfModule !modname). Refs #1793

History

#1 Updated by Davide Principi over 6 years ago

  • Due date set to 03/26/2013
  • Status changed from NEW to ON_DEV
  • Start date set to 03/26/2013
  • % Done changed from 0 to 80

#2 Updated by Davide Principi over 6 years ago

  • Status changed from ON_DEV to MODIFIED
  • % Done changed from 80 to 100

In nethserver-testing repository: nethserver-httpd-2.1.0-1.ns6.noarch.rpm

#3 Updated by Davide Principi over 6 years ago

  • Status changed from MODIFIED to CLOSED

Also available in: Atom PDF